python3-whoosh_2.7.4.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. SUMMARY = "Fast, pure-Python full text indexing, search, and spell checking library."
  2. DESCRIPTION = "\
  3. Whoosh is a fast, featureful full-text indexing and searching library \
  4. implemented in pure Python. Programmers can use it to easily add search \
  5. functionality to their applications and websites. Every part of how \
  6. Whoosh works can be extended or replaced to meet your needs exactly."
  7. LICENSE = "BSD-2-Clause"
  8. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05303186defc6141143629961c7c8a60"
  9. SRC_URI[md5sum] = "893433e9c0525ac043df33e6e04caab2"
  10. SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b45375dda69"
  11. PYPI_PACKAGE = "Whoosh"
  12. PYPI_PACKAGE_EXT = "zip"
  13. inherit ptest pypi setuptools3
  14. RDEPENDS_${PN} += " \
  15. ${PYTHON_PN}-email \
  16. ${PYTHON_PN}-multiprocessing \
  17. ${PYTHON_PN}-netclient \
  18. ${PYTHON_PN}-numbers \
  19. ${PYTHON_PN}-pickle \
  20. ${PYTHON_PN}-shell \
  21. ${PYTHON_PN}-stringold \
  22. "
  23. SRC_URI += " \
  24. file://run-ptest \
  25. "
  26. RDEPENDS_${PN}-ptest += " \
  27. ${PYTHON_PN}-pytest \
  28. ${PYTHON_PN}-fcntl \
  29. "
  30. do_install_ptest() {
  31. install -d ${D}${PTEST_PATH}/tests
  32. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  33. }