python3-werkzeug_1.0.1.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "The Swiss Army knife of Python web development"
  2. DESCRIPTION = "\
  3. Werkzeug started as simple collection of various utilities for WSGI \
  4. applications and has become one of the most advanced WSGI utility modules. \
  5. It includes a powerful debugger, full featured request and response objects, \
  6. HTTP utilities to handle entity tags, cache control headers, HTTP dates, \
  7. cookie handling, file uploads, a powerful URL routing system and a bunch \
  8. of community contributed addon modules."
  9. HOMEPAGE = "http://werkzeug.pocoo.org/"
  10. LICENSE = "BSD"
  11. LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
  12. PYPI_PACKAGE = "Werkzeug"
  13. SRC_URI[md5sum] = "5d499cfdd30de5d9c946994783772efd"
  14. SRC_URI[sha256sum] = "6c80b1e5ad3665290ea39320b91e1be1e0d5f60652b964a3070216de83d2e47c"
  15. inherit pypi setuptools3
  16. CLEANBROKEN = "1"
  17. RDEPENDS_${PN} += " \
  18. ${PYTHON_PN}-datetime \
  19. ${PYTHON_PN}-difflib \
  20. ${PYTHON_PN}-email \
  21. ${PYTHON_PN}-html \
  22. ${PYTHON_PN}-io \
  23. ${PYTHON_PN}-json \
  24. ${PYTHON_PN}-logging \
  25. ${PYTHON_PN}-netclient \
  26. ${PYTHON_PN}-netserver \
  27. ${PYTHON_PN}-numbers \
  28. ${PYTHON_PN}-pkgutil \
  29. ${PYTHON_PN}-pprint \
  30. ${PYTHON_PN}-simplejson \
  31. ${PYTHON_PN}-threading \
  32. ${PYTHON_PN}-unixadmin \
  33. ${PYTHON_PN}-misc \
  34. "