python3-webcolors_1.11.1.bb 661 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
  2. LICENSE = "BSD-3-Clause"
  3. LIC_FILES_CHKSUM = "file://LICENSE;md5=25b90379a52351261c51272e7923d240"
  4. SRC_URI[md5sum] = "54d28a7c80b3e4d974ec2fee86768be9"
  5. SRC_URI[sha256sum] = "76f360636957d1c976db7466bc71dcb713bb95ac8911944dffc55c01cb516de6"
  6. inherit pypi setuptools3 ptest
  7. RDEPENDS_${PN}_class-target = "\
  8. ${PYTHON_PN}-stringold \
  9. "
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. RDEPENDS_${PN}-ptest += " \
  14. ${PYTHON_PN}-pytest \
  15. "
  16. do_install_ptest() {
  17. install -d ${D}${PTEST_PATH}/tests
  18. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  19. }
  20. BBCLASSEXTEND = "native nativesdk"