python3-ujson_4.0.1.bb 851 B

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "Ultra fast JSON encoder and decoder for Python"
  2. DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
  3. LICENSE = "BSD-3-Clause"
  4. LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
  5. SRC_URI[md5sum] = "c8030a62912c3be18ff99fa5b25258b8"
  6. SRC_URI[sha256sum] = "26cf6241b36ff5ce4539ae687b6b02673109c5e3efc96148806a7873eaa229d3"
  7. inherit pypi ptest setuptools3
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
  12. RDEPENDS_${PN} += "\
  13. ${PYTHON_PN}-datetime \
  14. ${PYTHON_PN}-numbers \
  15. "
  16. RDEPENDS_${PN}-ptest += " \
  17. ${PYTHON_PN}-pytz \
  18. "
  19. do_install_ptest() {
  20. install -d ${D}${PTEST_PATH}/tests
  21. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  22. }
  23. BBCLASSEXTEND = "native nativesdk"