python3-typeguard_2.10.0.bb 783 B

12345678910111213141516171819202122232425262728293031
  1. SUMMARY = "Run-time type checker for Python"
  2. HOMEPAGE = "https://pypi.org/project/typeguard/"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
  5. SRC_URI[md5sum] = "cc43e0eb1dea7e409a74c7f1effc4544"
  6. SRC_URI[sha256sum] = "d830132dcd544d3f8a2a842ea739eaa0d7c099fcebb9dcdf3802f4c9929d8191"
  7. inherit pypi setuptools3 ptest
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. ${PYTHON_PN}-typing-extensions \
  14. ${PYTHON_PN}-unixadmin \
  15. "
  16. do_install_ptest() {
  17. install -d ${D}${PTEST_PATH}/tests
  18. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  19. }
  20. DEPENDS += "\
  21. python3-distutils-extra-native \
  22. python3-setuptools-scm-native \
  23. "
  24. BBCLASSEXTEND = "native nativesdk"