python3-soupsieve_2.1.bb 628 B

12345678910111213141516171819202122232425
  1. SUMMARY = "CSS selector library for python-beautifulsoup4"
  2. HOMEPAGE = "https://github.com/facelessuser/soupsieve"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5a6fd3b0c24fc5a041a3d1bbb22c81b5"
  5. SRC_URI[sha256sum] = "6dc52924dc0bc710a5d16794e6b3480b2c7c08b07729505feab2b2c16661ff6e"
  6. inherit pypi setuptools3 ptest
  7. SRC_URI += " \
  8. file://run-ptest \
  9. "
  10. RDEPENDS_${PN}-ptest += " \
  11. ${PYTHON_PN}-pytest \
  12. ${PYTHON_PN}-beautifulsoup4 \
  13. "
  14. do_install_ptest() {
  15. install -d ${D}${PTEST_PATH}/tests
  16. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  17. }
  18. BBCLASSEXTEND = "native nativesdk"