python3-slip-dbus_0.6.5.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "Convenience functions for dbus services in Python 2.x"
  2. HOMEPAGE = "https://github.com/nphilipp/python-slip"
  3. DESCRIPTION = "\
  4. The Simple Library for Python 2.x packages contain miscellaneous code for \
  5. convenience, extension and workaround purposes. \
  6. \
  7. This package provides slip.dbus.service.Object, which is a dbus.service.Object \
  8. derivative that ends itself after a certain time without being used and/or if \
  9. there are no clients anymore on the message bus, as well as convenience \
  10. functions and decorators for integrating a dbus service with PolicyKit."
  11. SECTION = "devel/python"
  12. LICENSE = "GPLv2+"
  13. LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
  14. SRCNAME = "python-slip"
  15. SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
  16. S = "${WORKDIR}/${SRCNAME}-${PV}"
  17. SRC_URI[md5sum] = "28ae5f93853466c44ec96706ba2a1eb4"
  18. SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
  19. do_compile_prepend() {
  20. sed -e 's/@VERSION@/${PV}/g' ${S}/setup.py.in > ${S}/setup.py
  21. }
  22. RDEPENDS_${PN} += "\
  23. ${PYTHON_PN}-six \
  24. "
  25. # http://errors.yoctoproject.org/Errors/Details/184713/
  26. # python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
  27. CLEANBROKEN = "1"
  28. inherit setuptools3