python3-semver_2.13.0.bb 679 B

123456789101112131415161718192021222324
  1. DESCRIPTION = "Python module for Semantic Versioning"
  2. HOMEPAGE = "https://github.com/k-bx/python-semver"
  3. BUGTRACKER = "https://github.com/k-bx/python-semver/issues"
  4. LICENSE = "BSD-3-Clause"
  5. LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
  6. SRC_URI[md5sum] = "e98b5fb283ea84daa5195087de83ebf1"
  7. SRC_URI[sha256sum] = "fa0fe2722ee1c3f57eac478820c3a5ae2f624af8264cbdf9000c980ff7f75e3f"
  8. inherit pypi setuptools3 ptest
  9. BBCLASSEXTEND = "native nativesdk"
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. RDEPENDS_${PN}-ptest += " \
  14. ${PYTHON_PN}-pytest \
  15. "
  16. do_install_ptest() {
  17. cp -f ${S}/test_semver.py ${D}${PTEST_PATH}/
  18. }