python3-requests-toolbelt_0.9.1.bb 956 B

12345678910111213141516171819202122232425262728293031323334
  1. DESCRIPTION = "A utility belt for advanced users of python-requests."
  2. HOMEPAGE = "https://toolbelt.readthedocs.org"
  3. AUTHOR = "Ian Cordasco, Cory Benfield"
  4. LICENSE = "Apache-2.0"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=71760e0f1dda8cff91b0bc9246caf571"
  6. SRC_URI = "file://run-ptest \
  7. "
  8. SRC_URI[md5sum] = "b1509735c4b4cf95df2619facbc3672e"
  9. SRC_URI[sha256sum] = "968089d4584ad4ad7c171454f0a5c6dac23971e9472521ea3b6d49d610aa6fc0"
  10. inherit pypi setuptools3 ptest
  11. RDEPENDS_${PN} += " \
  12. ${PYTHON_PN}-requests (>=2.0.1) \
  13. "
  14. RDEPENDS_${PN}-ptest += " \
  15. ${PYTHON_PN}-pytest \
  16. ${PYTHON_PN}-betamax \
  17. ${PYTHON_PN}-mock \
  18. ${PYTHON_PN}-multiprocessing \
  19. "
  20. do_install_ptest() {
  21. install -d ${D}${PTEST_PATH}/tests
  22. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  23. cp -rf ${S}/setup.py ${D}${PTEST_PATH}
  24. # remove test test_multipart_encoder.py as it fails,
  25. # downloaded file is not supported
  26. rm -f ${D}${PTEST_PATH}/tests/test_multipart_encoder.py
  27. }