python3-pyudev_0.22.0.bb 576 B

123456789101112131415161718192021222324
  1. SUMMARY = "A libudev binding"
  2. LICENSE = "LGPLv2.1+"
  3. LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
  4. SRC_URI[sha256sum] = "69bb1beb7ac52855b6d1b9fe909eefb0017f38d917cba9939602c6880035b276"
  5. inherit pypi setuptools3
  6. do_configure_prepend() {
  7. sed -i "/import pyudev/d" ${S}/setup.py
  8. sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
  9. }
  10. RDEPENDS_${PN} = "\
  11. ${PYTHON_PN}-ctypes \
  12. ${PYTHON_PN}-misc \
  13. ${PYTHON_PN}-six \
  14. ${PYTHON_PN}-threading \
  15. ${PYTHON_PN}-fcntl \
  16. libudev \
  17. "
  18. BBCLASSEXTEND = "native nativesdk"