python3-pynacl_1.4.0.bb 791 B

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "Python binding to the Networking and Cryptography (NaCl) library"
  2. DESCRIPTION = "Python binding to the Networking and Cryptography (NaCl) library"
  3. HOMEPAGE = "https://github.com/pyca/pynacl"
  4. LICENSE = "Apache-2.0"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=8cc789b082b3d97e1ccc5261f8594d3f"
  6. SRC_URI[md5sum] = "8c6c57893327a694c72510fb620e4744"
  7. SRC_URI[sha256sum] = "54e9a2c849c742006516ad56a88f5c74bf2ce92c9f67435187c3c5953b346505"
  8. PYPI_PACKAGE = "PyNaCl"
  9. inherit pypi setuptools3
  10. DEPENDS += "\
  11. ${PYTHON_PN}-wheel-native \
  12. ${PYTHON_PN}-cffi-native \
  13. libsodium \
  14. "
  15. RDEPENDS_${PN} = "\
  16. ${PYTHON_PN}-six \
  17. ${PYTHON_PN}-cffi \
  18. libsodium \
  19. "
  20. do_compile_prepend() {
  21. export SODIUM_INSTALL=system
  22. }
  23. do_install_prepend() {
  24. export SODIUM_INSTALL=system
  25. }