python3-pymongo_3.11.2.bb 991 B

123456789101112131415161718192021222324252627282930
  1. SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
  2. DESCRIPTION = "\
  3. The PyMongo distribution contains tools for interacting with MongoDB \
  4. database from Python. The bson package is an implementation of the BSON \
  5. format for Python. The pymongo package is a native Python driver for \
  6. MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
  7. HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
  8. LICENSE = "Apache-2.0"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
  10. SRC_URI[sha256sum] = "c2b67881392a9e85aa108e75f62cdbe372d5a3f17ea5f8d3436dcf4662052f14"
  11. inherit pypi setuptools3
  12. PACKAGES =+ "${PYTHON_PN}-bson"
  13. FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
  14. RDEPENDS_${PYTHON_PN}-bson += " \
  15. ${PYTHON_PN}-datetime \
  16. ${PYTHON_PN}-json \
  17. ${PYTHON_PN}-netclient \
  18. ${PYTHON_PN}-numbers \
  19. ${PYTHON_PN}-threading \
  20. "
  21. RDEPENDS_${PN} += " \
  22. ${PYTHON_PN}-bson \
  23. ${PYTHON_PN}-pprint \
  24. "