python3-pycrypto_2.6.1.bb 864 B

1234567891011121314151617181920212223242526272829
  1. DESCRIPTION = "Cryptographic modules for Python."
  2. HOMEPAGE = "http://www.pycrypto.org/"
  3. LICENSE = "PSFv2"
  4. LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
  5. DEPENDS += " gmp"
  6. export HOST_SYS
  7. inherit pypi autotools-brokensep distutils3
  8. SRC_URI += "file://cross-compiling.patch \
  9. file://CVE-2013-7459.patch \
  10. file://0001-Replace-time.clock-with-time.process_time.patch \
  11. "
  12. SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
  13. SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
  14. do_compile[noexec] = "1"
  15. # We explicitly call distutils_do_install, since we want it to run, but
  16. # *don't* want the autotools install to run, since this package doesn't
  17. # provide a "make install" target.
  18. do_install() {
  19. distutils3_do_install
  20. }
  21. BBCLASSEXTEND = "native nativesdk"