python3-pybind11_2.5.0.bb 792 B

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "Seamless operability between C++11 and Python"
  2. HOMEPAGE = "https://github.com/wjakob/pybind11"
  3. LICENSE = "BSD-2-Clause"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=beb87117af69fd10fbf9fb14c22a2e62"
  5. DEPENDS = "boost"
  6. SRC_URI = "git://github.com/pybind/pybind11.git \
  7. file://0001-Do-not-strip-binaries.patch \
  8. file://0001-Do-not-check-pointer-size-when-cross-compiling.patch \
  9. "
  10. SRCREV = "3b1dbebabc801c9cf6f0953a4c20b904d444f879"
  11. S = "${WORKDIR}/git"
  12. BBCLASSEXTEND = "native"
  13. EXTRA_OECMAKE = "-DPYBIND11_TEST=OFF"
  14. inherit cmake setuptools3 python3native
  15. do_configure() {
  16. cmake_do_configure
  17. }
  18. do_compile() {
  19. distutils3_do_compile
  20. cmake_do_compile
  21. }
  22. do_install() {
  23. distutils3_do_install
  24. cmake_do_install
  25. }
  26. BBCLASSEXTEND = "native nativesdk"