python3-pyasn1-modules_0.2.8.bb 852 B

1234567891011121314151617181920212223242526272829
  1. SUMMARY = "A collection of ASN.1-based protocols modules."
  2. DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\
  3. classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\
  4. data structures (X.509, PKCS etc.)."
  5. HOMEPAGE = "https://github.com/etingof/pyasn1-modules"
  6. LICENSE = "BSD-2-Clause"
  7. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd"
  8. SRC_URI[md5sum] = "107e1ece7d0a41d782f69f8a95a4d9bc"
  9. SRC_URI[sha256sum] = "905f84c712230b2c592c19470d3ca8d552de726050d1d1716282a1f6146be65e"
  10. inherit pypi ptest setuptools3
  11. RDEPENDS_${PN} = "${PYTHON_PN}-pyasn1"
  12. BBCLASSEXTEND = "native nativesdk"
  13. SRC_URI += " \
  14. file://run-ptest \
  15. "
  16. RDEPENDS_${PN}-ptest += " \
  17. ${PYTHON_PN}-pytest \
  18. "
  19. do_install_ptest() {
  20. install -d ${D}${PTEST_PATH}/tests
  21. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  22. }