python3-protobuf_3.12.2.bb 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. DESCRIPTION = "Protocol Buffers"
  2. HOMEPAGE = "https://developers.google.com/protocol-buffers/"
  3. SECTION = "devel/python"
  4. LICENSE = "BSD-3-Clause"
  5. LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
  6. inherit pypi setuptools3
  7. SRC_URI[md5sum] = "b4336acee38ebe915b6e72fe8c5bce7b"
  8. SRC_URI[sha256sum] = "49ef8ab4c27812a89a76fa894fe7a08f42f2147078392c0dee51d4a444ef6df5"
  9. # http://errors.yoctoproject.org/Errors/Details/184715/
  10. # Can't find required file: ../src/google/protobuf/descriptor.proto
  11. CLEANBROKEN = "1"
  12. UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
  13. DEPENDS += "protobuf"
  14. RDEPENDS_${PN} += " \
  15. ${PYTHON_PN}-datetime \
  16. ${PYTHON_PN}-json \
  17. ${PYTHON_PN}-logging \
  18. ${PYTHON_PN}-netclient \
  19. ${PYTHON_PN}-numbers \
  20. ${PYTHON_PN}-pkgutil \
  21. ${PYTHON_PN}-six \
  22. ${PYTHON_PN}-unittest \
  23. "
  24. # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
  25. BBCLASSEXTEND = "native nativesdk"
  26. DISTUTILS_BUILD_ARGS += "--cpp_implementation"
  27. DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
  28. do_compile_prepend_class-native () {
  29. export KOKORO_BUILD_NUMBER="1"
  30. }