python3-prettytable_2.0.0.bb 1003 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. SUMMARY = "Python library for displaying tabular data in a ASCII table format"
  2. HOMEPAGE = "http://code.google.com/p/prettytable"
  3. LICENSE = "BSD-3-Clause"
  4. LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
  5. SRC_URI[sha256sum] = "e37acd91976fe6119172771520e58d1742c8479703489321dc1d9c85e7259922"
  6. do_install_append() {
  7. perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
  8. for f in $perm_files; do
  9. chmod 644 "${f}"
  10. done
  11. }
  12. UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
  13. UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
  14. BBCLASSEXTEND = "native nativesdk"
  15. inherit pypi ptest setuptools3
  16. SRC_URI += " \
  17. file://run-ptest \
  18. "
  19. DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
  20. RDEPENDS_${PN} += " \
  21. ${PYTHON_PN}-math \
  22. ${PYTHON_PN}-html \
  23. ${PYTHON_PN}-wcwidth \
  24. "
  25. RDEPENDS_${PN}-ptest += " \
  26. ${PYTHON_PN}-pytest \
  27. "
  28. do_install_ptest() {
  29. cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
  30. }