python3-precise-runner_0.3.1.bb 591 B

12345678910111213141516171819202122
  1. SUMMARY = "A lightweight, simple-to-use, RNN wake word listener."
  2. HOMEPAGE = "https://github.com/MycroftAI/mycroft-precise"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://README.md;md5=2ad29e930f3107d52d2a55728bf62116"
  5. SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf"
  6. SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d"
  7. inherit pypi setuptools3 ptest
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. "
  14. do_install_ptest() {
  15. install -d ${D}${PTEST_PATH}/test
  16. cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
  17. }