python3-polyline_1.4.0.bb 657 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
  2. HOMEPAGE = "https://pypi.org/project/polyline/"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6"
  5. SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb"
  6. SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074"
  7. inherit pypi setuptools3 ptest
  8. RDEPENDS_${PN} += "python3-six"
  9. BBCLASSEXTEND = "native nativesdk"
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. RDEPENDS_${PN}-ptest += " \
  14. ${PYTHON_PN}-pytest \
  15. "
  16. do_install_ptest() {
  17. install -d ${D}${PTEST_PATH}/test
  18. cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
  19. }