python3-pint_0.16.1.bb 835 B

123456789101112131415161718192021222324252627282930313233343536
  1. SUMMARY = "Physical quantities module"
  2. DESCRIPTION = "Physical quantities Python module"
  3. HOMEPAGE = "https://github.com/hgrecco/pint"
  4. SECTION = "devel/python"
  5. LICENSE = "BSD-3-Clause"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
  7. PYPI_PACKAGE := "Pint"
  8. inherit pypi ptest setuptools3
  9. SRC_URI[md5sum] = "d4a7bbdf505dee964eb1e5e6e7f80c34"
  10. SRC_URI[sha256sum] = "d43a2e9ae003164978b60fdf8cd920d8581e1a5991df8dded29b00f4850ec83a"
  11. DEPENDS += "python3-setuptools-scm-native"
  12. BBCLASSEXTEND = "native nativesdk"
  13. SRC_URI += " \
  14. file://run-ptest \
  15. "
  16. RDEPENDS_${PN} += " \
  17. ${PYTHON_PN}-setuptools \
  18. ${PYTHON_PN}-packaging \
  19. "
  20. RDEPENDS_${PN}-ptest += " \
  21. ${PYTHON_PN}-pytest \
  22. "
  23. do_install_ptest() {
  24. install -d ${D}${PTEST_PATH}/testsuite
  25. cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
  26. }