python3-parse_1.18.0.bb 642 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Parse strings using a specification based on the Python format() syntax"
  2. HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
  5. SRC_URI[md5sum] = "42ea0002cf36bfd2bd74f3c05bf25f60"
  6. SRC_URI[sha256sum] = "91666032d6723dc5905248417ef0dc9e4c51df9526aaeef271eacad6491f06a4"
  7. inherit pypi setuptools3 ptest
  8. RDEPENDS_${PN} += "\
  9. ${PYTHON_PN}-datetime \
  10. ${PYTHON_PN}-logging \
  11. "
  12. SRC_URI += " \
  13. file://run-ptest \
  14. "
  15. RDEPENDS_${PN}-ptest += " \
  16. ${PYTHON_PN}-pytest \
  17. "
  18. do_install_ptest() {
  19. cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
  20. }