python3-parse-type_0.5.2.bb 676 B

12345678910111213141516171819202122232425
  1. SUMMARY = "Simplifies building parse types based on the parse module"
  2. HOMEPAGE = "https://github.com/jenisys/parse_type"
  3. LICENSE = "BSD-3-Clause"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=16374dbaeaca1890153edb3f41371222"
  5. SRC_URI[md5sum] = "b954062f14ab723a91fe1e2be15e859d"
  6. SRC_URI[sha256sum] = "7f690b18d35048c15438d6d0571f9045cffbec5907e0b1ccf006f889e3a38c0b"
  7. PYPI_PACKAGE = "parse_type"
  8. inherit pypi ptest setuptools3
  9. RDEPENDS_${PN} += "${PYTHON_PN}-parse ${PYTHON_PN}-six"
  10. SRC_URI += " \
  11. file://run-ptest \
  12. "
  13. RDEPENDS_${PN}-ptest += " \
  14. ${PYTHON_PN}-pytest \
  15. "
  16. do_install_ptest() {
  17. install -d ${D}${PTEST_PATH}/tests
  18. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  19. }