python3-pandas_1.2.0.bb 779 B

123456789101112131415161718192021222324
  1. SUMMARY = "pandas library for high-performance data analysis tools"
  2. DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
  3. high-performance, easy-to-use data structures and data analysis tools for \
  4. the Python programming language."
  5. HOMEPAGE = "http://pandas.pydata.org/"
  6. LICENSE = "BSD-3-Clause"
  7. LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774"
  8. SRC_URI[sha256sum] = "e03386615b970b8b41da6a68afe717626741bb2431cec993640685614c0680e4"
  9. inherit pypi setuptools3
  10. DEPENDS += " \
  11. ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
  12. "
  13. CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
  14. RDEPENDS_${PN} += " \
  15. ${PYTHON_PN}-json \
  16. ${PYTHON_PN}-numpy \
  17. ${PYTHON_PN}-dateutil \
  18. ${PYTHON_PN}-pytz \
  19. "