python3-ordered-set_4.0.2.bb 609 B

1234567891011121314151617181920212223
  1. SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
  2. HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
  5. SRC_URI[md5sum] = "5d88f3870c32d4868b28c8fe833f7e74"
  6. SRC_URI[sha256sum] = "ba93b2df055bca202116ec44b9bead3df33ea63a7d5827ff8e16738b97f33a95"
  7. inherit pypi setuptools3 ptest
  8. DEPENDS += "python3-pytest-runner-native"
  9. SRC_URI += " \
  10. file://run-ptest \
  11. "
  12. RDEPENDS_${PN}-ptest += " \
  13. ${PYTHON_PN}-pytest \
  14. "
  15. do_install_ptest() {
  16. cp -f ${S}/test.py ${D}${PTEST_PATH}/
  17. }