python3-multidict_5.1.0.bb 589 B

123456789101112131415161718192021222324
  1. SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
  2. HOMEPAGE = "https://github.com/aio-libs/multidict/"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
  5. SRC_URI[sha256sum] = "25b4e5f22d3a37ddf3effc0710ba692cfc792c2b9edfb9c05aefe823256e84d5"
  6. inherit pypi setuptools3 ptest
  7. SRC_URI += " \
  8. file://run-ptest \
  9. "
  10. RDEPENDS_${PN}-ptest += " \
  11. ${PYTHON_PN}-pytest \
  12. "
  13. do_install_ptest() {
  14. install -d ${D}${PTEST_PATH}/tests
  15. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  16. }
  17. BBCLASSEXTEND = "native nativesdk"