python3-matplotlib_3.3.2.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. SUMMARY = "matplotlib: plotting with Python"
  2. DESCRIPTION = "\
  3. Matplotlib is a Python 2D plotting library which produces \
  4. publication-quality figures in a variety of hardcopy formats \
  5. and interactive environments across platforms."
  6. HOMEPAGE = "https://github.com/matplotlib/matplotlib"
  7. SECTION = "devel/python"
  8. LICENSE = "PSF"
  9. LIC_FILES_CHKSUM = "\
  10. file://setup.py;beginline=259;endline=259;md5=e0ef37de7122ce842bcd1fb54482b353 \
  11. file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
  12. "
  13. DEPENDS = "\
  14. freetype \
  15. libpng \
  16. python3-numpy-native \
  17. python3-dateutil-native \
  18. python3-pytz-native \
  19. python3-certifi-native \
  20. "
  21. SRC_URI[md5sum] = "a85791908e78818bd425ba9ab38500fa"
  22. SRC_URI[sha256sum] = "3d2edbf59367f03cd9daf42939ca06383a7d7803e3993eb5ff1bee8e8a3fbb6b"
  23. inherit pypi setuptools3 pkgconfig
  24. # LTO with clang needs lld
  25. LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
  26. LDFLAGS_remove_toolchain-clang_mips = "-fuse-ld=lld"
  27. RDEPENDS_${PN} = "\
  28. freetype \
  29. libpng \
  30. python3-numpy \
  31. python3-pyparsing \
  32. python3-cycler \
  33. python3-dateutil \
  34. python3-kiwisolver \
  35. python3-pytz \
  36. "
  37. ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
  38. ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
  39. ENABLELTO_toolchain-clang_mips = "echo enable_lto = False >> ${S}/setup.cfg"
  40. do_compile_prepend() {
  41. echo [libs] > ${S}/setup.cfg
  42. echo system_freetype = true >> ${S}/setup.cfg
  43. ${ENABLELTO}
  44. }
  45. BBCLASSEXTEND = "native"