python3-lockfile_0.12.2.bb 679 B

1234567891011121314151617
  1. # This recipe is originally from meta-openstack:
  2. # https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
  3. SUMMARY = "Platform-independent file locking module"
  4. HOMEPAGE = "https://pypi.org/project/lockfile/"
  5. LICENSE = "MIT"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
  7. SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
  8. SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
  9. inherit pypi setuptools3
  10. DEPENDS += "python3-distutils-extra-native python3-pbr-native"
  11. RDEPENDS_${PN} += "python3-sqlite3"
  12. BBCLASSEXTEND = "native nativesdk"