python3-iso3166_1.0.1.bb 643 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Self-contained ISO 3166-1 country definitions"
  2. HOMEPAGE = "https://pypi.org/project/iso3166/"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
  5. SRC_URI[md5sum] = "53c313c7ae8721e40ddd5e7a01bbcb7e"
  6. SRC_URI[sha256sum] = "b1e58dbcf50fbb2c9c418ec7a6057f0cdb30b8f822ac852f72e71ba769dae8c5"
  7. inherit pypi setuptools3 ptest
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. "
  14. do_install_ptest() {
  15. install -d ${D}${PTEST_PATH}/tests
  16. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  17. }
  18. RDEPENDS_${PN} += "python3-numbers"
  19. BBCLASSEXTEND = "native nativesdk"