python3-ipy_1.00.bb 951 B

1234567891011121314151617181920212223242526272829303132
  1. SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
  2. DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
  3. in a fashion similar to perl's Net::IP and friends. The IP class allows \
  4. a comfortable parsing and handling for most notations in use for IPv4 \
  5. and IPv6 Addresses and Networks."
  6. SECTION = "devel/python"
  7. HOMEPAGE = "https://github.com/autocracy/python-ipy"
  8. LICENSE = "BSD-3-Clause"
  9. LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
  10. SRC_URI[md5sum] = "1a90c68174234672241a7e60c7ea0fb9"
  11. SRC_URI[sha256sum] = "2f2bf658a858d43868d8a4352b3889cf78c66e2ce678b300dcf518c9149ba621"
  12. inherit pypi setuptools3 ptest
  13. SRC_URI += " \
  14. file://run-ptest \
  15. "
  16. RDEPENDS_${PN}-ptest += " \
  17. ${PYTHON_PN}-pytest \
  18. "
  19. do_install_ptest() {
  20. install -d ${D}${PTEST_PATH}/test/
  21. cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
  22. }
  23. PYPI_PACKAGE = "IPy"
  24. BBCLASSEXTEND = "native"