python3-inflection_0.5.1.bb 638 B

123456789101112131415161718192021222324252627
  1. SUMMARY = "A port of Ruby on Rails' inflection to Python."
  2. HOMEPAGE = "https://pypi.org/project/inflection"
  3. LICENSE = "MIT"
  4. SECTION = "devel/python"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
  6. SRC_URI[md5sum] = "c3287d4f0e3bdf625a52d655cc514403"
  7. SRC_URI[sha256sum] = "1a29730d366e996aaacffb2f1f1cb9593dc38e2ddd30c91250c6dde09ea9b417"
  8. inherit pypi setuptools3 ptest
  9. SRC_URI +=" \
  10. file://run-ptest \
  11. "
  12. RDEPENDS_${PN}_ptest +=" \
  13. ${PYTHON_PN}_pytest \
  14. "
  15. do_install_ptest() {
  16. cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
  17. }
  18. RDEPENDS_${PN} += "${PYTHON_PN}-pytest"
  19. BBCLASSEXTEND = "native nativesdk"