python3-incremental_17.5.0.bb 803 B

1234567891011121314151617181920
  1. DESCRIPTION = "Incremental is a small library that versions your Python projects"
  2. HOMEPAGE = "https://github.com/twisted/incremental"
  3. LICENSE = "MIT"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
  5. SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
  6. SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
  7. inherit pypi setuptools3
  8. RDEPENDS_${PN} += " \
  9. ${PYTHON_PN}-twisted \
  10. ${PYTHON_PN}-click \
  11. "
  12. # -native is needed to build python[3]-twisted, however, we need to take steps to
  13. # prevent a circular dependency. The build apparently does not use the part of
  14. # python-incremental which uses python-twisted, so this hack is OK.
  15. RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
  16. BBCLASSEXTEND = "native"