python3-gunicorn_20.0.4.bb 564 B

123456789101112131415161718192021222324
  1. SUMMARY = "WSGI HTTP Server for UNIX"
  2. LICENSE = "MIT"
  3. LIC_FILES_CHKSUM = "file://LICENSE;md5=f75f3fb94cdeab1d607e2adaa6077752"
  4. SRC_URI[md5sum] = "543669fcbb5739ee2af77184c5e571a1"
  5. SRC_URI[sha256sum] = "1904bb2b8a43658807108d59c3f3d56c2b6121a701161de0ddf9ad140073c626"
  6. inherit pypi setuptools3 ptest
  7. SRC_URI += " \
  8. file://run-ptest \
  9. "
  10. RDEPENDS_${PN}-ptest += " \
  11. ${PYTHON_PN}-pytest \
  12. "
  13. do_install_ptest() {
  14. install -d ${D}${PTEST_PATH}/tests
  15. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  16. }
  17. RDEPENDS_${PN} += "${PYTHON_PN}-setuptools ${PYTHON_PN}-fcntl"