python3-gevent_20.9.0.bb 1.3 KB

12345678910111213141516171819202122232425262728293031323334
  1. SUMMARY = "A coroutine-based Python networking library"
  2. DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
  3. a high-level synchronous API on top of the libevent event loop."
  4. HOMEPAGE = "http://www.gevent.org"
  5. LICENSE = "MIT & Python-2.0 & BSD"
  6. LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \
  7. file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \
  8. file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \
  9. "
  10. DEPENDS += "libevent"
  11. DEPENDS += "${PYTHON_PN}-greenlet"
  12. RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \
  13. ${PYTHON_PN}-mime \
  14. ${PYTHON_PN}-pprint \
  15. "
  16. FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:"
  17. SRC_URI_append = " \
  18. file://libev-conf.patch;patch=1;pnum=1 \
  19. "
  20. SRC_URI[md5sum] = "9366ee7eebed48003f8a748568ef1f70"
  21. SRC_URI[sha256sum] = "5f6d48051d336561ec08995431ee4d265ac723a64bba99cc58c3eb1a4d4f5c8d"
  22. # The python-gevent has no autoreconf ability
  23. # and the logic for detecting a cross compile is flawed
  24. # so always force a cross compile
  25. do_configure_append() {
  26. sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
  27. sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
  28. }
  29. inherit pypi setuptools3