python3-geojson_2.5.0.bb 655 B

1234567891011121314151617181920212223242526
  1. SUMMARY = "Python bindings and utilities for GeoJSON"
  2. HOMEPAGE = "https://pypi.org/project/geojson/"
  3. LICENSE = "BSD"
  4. LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f48972abe5cddee79e301574742ed745"
  5. SRC_URI[md5sum] = "14753ed28678828b1de73f68b04e2324"
  6. SRC_URI[sha256sum] = "6e4bb7ace4226a45d9c8c8b1348b3fc43540658359f93c3f7e03efa9f15f658a"
  7. inherit pypi setuptools3 ptest
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. "
  14. do_install_ptest() {
  15. install -d ${D}${PTEST_PATH}/tests
  16. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  17. }
  18. RDEPENDS_${PN} += "python3-simplejson python3-math"
  19. BBCLASSEXTEND = "native nativesdk"