python3-cryptography_3.2.bb 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. SUMMARY = "Provides cryptographic recipes and primitives to python developers"
  2. HOMEPAGE = "https://cryptography.io/"
  3. SECTION = "devel/python"
  4. LICENSE = "Apache-2.0 | BSD"
  5. LIC_FILES_CHKSUM = "file://LICENSE;md5=097f805837700cfac572ac274cd38124"
  6. LDSHARED += "-pthread"
  7. SRC_URI[md5sum] = "1e476287399bae923514e19429804155"
  8. SRC_URI[sha256sum] = "e4789b84f8dedf190148441f7c5bfe7244782d9cbb194a36e17b91e7d3e1cca9"
  9. SRC_URI += " \
  10. file://run-ptest \
  11. file://h-test.patch \
  12. "
  13. inherit pypi setuptools3
  14. DEPENDS += " \
  15. ${PYTHON_PN}-cffi \
  16. ${PYTHON_PN}-cffi-native \
  17. ${PYTHON_PN}-asn1crypto \
  18. ${PYTHON_PN}-six \
  19. "
  20. RDEPENDS_${PN} += " \
  21. ${PYTHON_PN}-cffi \
  22. ${PYTHON_PN}-idna \
  23. ${PYTHON_PN}-asn1crypto \
  24. ${PYTHON_PN}-setuptools \
  25. ${PYTHON_PN}-six \
  26. "
  27. RDEPENDS_${PN}_class-target += " \
  28. ${PYTHON_PN}-cffi \
  29. ${PYTHON_PN}-idna \
  30. ${PYTHON_PN}-numbers \
  31. ${PYTHON_PN}-asn1crypto \
  32. ${PYTHON_PN}-setuptools \
  33. ${PYTHON_PN}-six \
  34. ${PYTHON_PN}-threading \
  35. "
  36. RDEPENDS_${PN}-ptest += " \
  37. ${PN} \
  38. ${PYTHON_PN}-cryptography-vectors \
  39. ${PYTHON_PN}-iso8601 \
  40. ${PYTHON_PN}-pretend \
  41. ${PYTHON_PN}-pytest \
  42. ${PYTHON_PN}-pytz \
  43. "
  44. inherit ptest
  45. do_install_ptest() {
  46. install -d ${D}${PTEST_PATH}/tests
  47. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  48. install -d ${D}${PTEST_PATH}/tests/hazmat
  49. cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
  50. }
  51. FILES_${PN}-dbg += " \
  52. ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
  53. "
  54. BBCLASSEXTEND = "native nativesdk"