python3-betamax_0.8.1.bb 600 B

1234567891011121314151617181920212223
  1. DESCRIPTION = "VCR imitation for python requests"
  2. HOMEPAGE = "https://github.com/betamaxpy/betamax"
  3. LICENSE = "Apache-2.0"
  4. LIC_FILES_CHKSUM = "file://LICENSE;md5=61c15f0c146c5fb1a8ce8ba2f310d73c"
  5. SRC_URI += " \
  6. file://run-ptest \
  7. "
  8. SRC_URI[md5sum] = "b8182d43a200fc126a3bf7555626f964"
  9. SRC_URI[sha256sum] = "5bf004ceffccae881213fb722f34517166b84a34919b92ffc14d1dbd050b71c2"
  10. inherit pypi setuptools3 ptest
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. ${PYTHON_PN}-requests \
  14. "
  15. do_install_ptest() {
  16. install -d ${D}${PTEST_PATH}/tests
  17. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  18. }