python3-bcrypt_3.2.0.bb 718 B

123456789101112131415161718192021222324252627282930
  1. DESCRIPTION = "Modern password hashing for your software and your servers."
  2. LICENSE = "Apache-2.0"
  3. LIC_FILES_CHKSUM = "file://LICENSE;md5=8f7bb094c7232b058c7e9f2e431f389c"
  4. DEPENDS += "${PYTHON_PN}-cffi-native"
  5. SRC_URI[md5sum] = "fe31390dab603728f756cd3d6830c80a"
  6. SRC_URI[sha256sum] = "5b93c1726e50a93a033c36e5ca7fdcd29a5c7395af50a6892f5d9e7c6cfbfb29"
  7. inherit pypi setuptools3 ptest
  8. SRC_URI += " \
  9. file://run-ptest \
  10. "
  11. RDEPENDS_${PN}-ptest += " \
  12. ${PYTHON_PN}-pytest \
  13. "
  14. do_install_ptest() {
  15. install -d ${D}${PTEST_PATH}/tests
  16. cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
  17. }
  18. RDEPENDS_${PN}_class-target += "\
  19. ${PYTHON_PN}-cffi \
  20. ${PYTHON_PN}-ctypes \
  21. ${PYTHON_PN}-shell \
  22. ${PYTHON_PN}-six \
  23. "