python3-async-timeout_3.0.1.bb 718 B

12345678910111213141516171819
  1. SUMMARY = "asyncio-compatible timeout context manager"
  2. DESCRIPTION = "\
  3. The context manager is useful in cases when you want to apply \
  4. timeout logic around block of code or in cases when asyncio.wait_for() \
  5. is not suitable. Also it's much faster than asyncio.wait_for() because \
  6. timeout doesn't create a new task."
  7. HOMEPAGE = "https://github.com/aio-libs/async-timeout"
  8. LICENSE = "Apache-2.0"
  9. LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
  10. SRC_URI[md5sum] = "305c4fa529f2485c403d0dbe14390175"
  11. SRC_URI[sha256sum] = "0c3c816a028d47f659d6ff5c745cb2acf1f966da1fe5c19c77a70282b25f4c5f"
  12. PYPI_PACKAGE = "async-timeout"
  13. inherit pypi setuptools3
  14. RDEPENDS_${PN} = "\
  15. ${PYTHON_PN}-asyncio \
  16. "