packagegroup-meta-python.bb 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453
  1. SUMMARY = "Meta-python ptest packagegroups"
  2. inherit packagegroup
  3. PROVIDES = "${PACKAGES}"
  4. PACKAGES = ' \
  5. packagegroup-meta-python3 \
  6. '
  7. RDEPENDS_packagegroup-meta-python3 = "\
  8. packagegroup-meta-python3-extended \
  9. packagegroup-meta-python3-connectivity \
  10. "
  11. RDEPENDS_packagegroup-meta-python3 = "\
  12. pamela \
  13. pyrtm \
  14. ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
  15. python3-bcrypt \
  16. python3-flask-mail \
  17. python3-editor \
  18. python3-flask-pymongo \
  19. python3-cffi \
  20. python3-pillow \
  21. python3-markupsafe \
  22. python3-flask-nav \
  23. python3-asciitree \
  24. python3-flask-sqlalchemy \
  25. python3-gevent \
  26. python3-aenum \
  27. python3-gast \
  28. python3-blinker \
  29. python3-prettytable \
  30. python3-cmd2 \
  31. python3-aiofiles \
  32. python3-anyjson \
  33. python3-isodate \
  34. python3-incremental \
  35. python3-aiohttp-jinja2 \
  36. python3-aiohttp \
  37. python3-alembic \
  38. python3-ansi2html \
  39. python3-ansicolors \
  40. python3-argcomplete \
  41. python3-argexec \
  42. python3-appdirs \
  43. python3-apply-defaults \
  44. python3-argh \
  45. python3-ply \
  46. python3-astroid \
  47. python3-ndg-httpsclient \
  48. python3-arpeggio \
  49. python3-astor \
  50. python3-pika \
  51. python3-asn1crypto \
  52. python3-async-timeout \
  53. python3-absl \
  54. python3-attr \
  55. python3-flask \
  56. python3-autobahn \
  57. python3-babel \
  58. python3-pretend \
  59. python3-automat \
  60. python3-ptyprocess \
  61. python3-aws-iot-device-sdk-python \
  62. python3-bandit \
  63. python3-backcall \
  64. python3-backports-functools-lru-cache \
  65. python3-beautifulsoup4 \
  66. python3-betamax \
  67. python3-behave \
  68. python3-jsonpointer \
  69. python3-bitarray \
  70. python3-bitstring \
  71. python3-bitstruct \
  72. python3-cachecontrol \
  73. python3-booleanpy \
  74. python3-cachetools \
  75. python3-can \
  76. python3-cantools \
  77. python3-cassandra-driver \
  78. python3-cbor2 \
  79. python3-chardet \
  80. python3-certifi \
  81. python3-isort \
  82. python3-colorama \
  83. python3-cheetah \
  84. python3-click \
  85. python3-huey \
  86. python3-coloredlogs \
  87. python3-colorlog \
  88. python3-wheel \
  89. python3-configshell-fb \
  90. python3-constantly \
  91. python3-contextlib2 \
  92. python3-configargparse \
  93. python3-crcmod \
  94. python3-configobj \
  95. python3-configparser \
  96. python3-cppy \
  97. python3-dbussy \
  98. python3-dateutil \
  99. python3-distro \
  100. python3-click-repl \
  101. python3-redis \
  102. python3-dominate \
  103. python3-et-xmlfile \
  104. python3-feedformatter \
  105. python3-flask-jsonpify \
  106. python3-flask-jwt \
  107. python3-flask-migrate \
  108. python3-pyinotify \
  109. python3-flask-restful \
  110. python3-flask-socketio \
  111. python3-gmqtt \
  112. python3-dateparser \
  113. python3-defusedxml \
  114. python3-rsa \
  115. python3-django-south \
  116. python3-grpcio \
  117. python3-pybind11-json \
  118. python3-google-api-python-client \
  119. python3-h5py \
  120. python3-dt-schema \
  121. python3-haversine \
  122. python3-fasteners \
  123. python3-flask-bootstrap \
  124. python3-dbus-next \
  125. python3-dnspython \
  126. python3-traitlets \
  127. python3-pybind11 \
  128. python3-flask-script \
  129. python3-flask-sijax \
  130. python3-html2text \
  131. python3-html5lib \
  132. python3-intervals \
  133. python3-ipy \
  134. python3-ipaddress \
  135. python3-iso8601 \
  136. python3-humanfriendly \
  137. python3-lrparsing \
  138. python3-itsdangerous \
  139. python3-hyperlink \
  140. python3-idna-ssl \
  141. python3-jdcal \
  142. python3-greenstalk \
  143. python3-icu \
  144. python3-jsonschema \
  145. python3-keras-applications \
  146. python3-idna \
  147. python3-sympy \
  148. python3-langtable \
  149. python3-lockfile \
  150. python3-nmap \
  151. python3-jdatetime \
  152. python3-monotonic \
  153. python3-mpmath \
  154. python3-jedi \
  155. python3-jsonpatch \
  156. python3-jsonrpcserver \
  157. python3-libconf \
  158. python3-netifaces \
  159. python3-msm \
  160. python3-nocaselist \
  161. python3-keras-preprocessing \
  162. python3-flask-babel \
  163. python3-lorem \
  164. python3-javaobj-py3 \
  165. python3-passlib \
  166. python3-pexpect \
  167. python3-luma-oled \
  168. python3-lxml \
  169. python3-precise-runner \
  170. python3-padaos \
  171. python3-progress \
  172. python3-sqlalchemy \
  173. python3-sh \
  174. python3-petact \
  175. python3-mock \
  176. python3-msgpack \
  177. python3-pyasn1 \
  178. python3-msk \
  179. python3-openpyxl \
  180. python3-prctl \
  181. python3-pyatspi \
  182. python3-multidict \
  183. python3-netaddr \
  184. python3-parse \
  185. python3-oauthlib \
  186. python3-pyfirmata \
  187. python3-pandas \
  188. python3-padatious \
  189. python3-prompt-toolkit \
  190. python3-parse-type \
  191. python3-cycler \
  192. python3-decorator \
  193. python3-django \
  194. python3-croniter \
  195. python3-flask-user \
  196. python3-twitter \
  197. python3-evdev \
  198. python3-dynamic-dispatch \
  199. python3-click-spinner \
  200. python3-future \
  201. python3-geojson \
  202. python3-gunicorn \
  203. python3-engineio \
  204. python3-gmpy2 \
  205. python3-coverage \
  206. python3-fastnumbers \
  207. python3-fann2 \
  208. python3-gnupg \
  209. python3-flask-login \
  210. python3-pyzmq \
  211. python3-cryptography-vectors \
  212. python3-flask-uploads \
  213. python3-ecdsa \
  214. python3-networkx \
  215. python3-flask-xstatic \
  216. python3-pint \
  217. python3-iso3166 \
  218. python3-imageio \
  219. python3-mccabe \
  220. python3-kconfiglib \
  221. python3-grpcio-tools \
  222. python3-jsmin \
  223. python3-greenlet \
  224. python3-idna \
  225. python3-flask-versioned \
  226. python3-httplib2 \
  227. python3-ipython-genutils \
  228. python3-kiwisolver \
  229. python3-lz4 \
  230. python3-obd \
  231. python3-markdown \
  232. python3-m2crypto \
  233. python3-paho-mqtt \
  234. python3-graphviz \
  235. python3-pyaudio \
  236. python3-pako \
  237. python3-meld3 \
  238. python3-parallax \
  239. python3-lazy-object-proxy \
  240. python3-license-expression \
  241. python3-luma-core \
  242. python3-natsort \
  243. python3-polyline \
  244. python3-ordered-set \
  245. python3-parso \
  246. python3-pycparser \
  247. python3-pycrypto \
  248. python3-pydbus \
  249. python3-pathtools3 \
  250. python3-periphery \
  251. python3-pyiface \
  252. python3-pyjwt \
  253. python3-pykwalify \
  254. python3-docopt \
  255. python3-pylint \
  256. python3-pynetlinux \
  257. python3-pickleshare \
  258. python3-pyopenssl \
  259. python3-protobuf \
  260. python3-pyasn1-modules \
  261. python3-pyscaffold \
  262. python3-pyserial \
  263. python3-pysocks \
  264. python3-pytoml \
  265. python3-pytest-helpers-namespace \
  266. python3-pytest-tempdir \
  267. python3-pyflakes \
  268. python3-pyrad \
  269. python3-pyusb \
  270. python3-pyhamcrest \
  271. python3-custom-inherit \
  272. python3-pymysql \
  273. python3-pyperclip \
  274. python3-rfc3339-validator \
  275. python3-pytz \
  276. python3-scrypt \
  277. python3-rdflib \
  278. python3-sijax \
  279. python3-regex \
  280. python3-slip-dbus \
  281. python3-smbus2 \
  282. python3-pytest-metadata \
  283. python3-term \
  284. python3-pystache \
  285. python3-pep8 \
  286. python3-pytest-runner \
  287. python3-pybluez \
  288. python3-rfc3986-validator \
  289. python3-pocketsphinx \
  290. python3-sdnotify \
  291. python3-pycodestyle \
  292. python3-speaklater \
  293. python3-wtforms \
  294. python3-speedtest-cli \
  295. python3-pyudev \
  296. python3-sqlparse \
  297. python3-pyexpect \
  298. python3-pytest-html \
  299. python3-uritemplate \
  300. python3-cryptography \
  301. python3-requests \
  302. python3-test-generator \
  303. python3-whoosh \
  304. python3-xstatic-font-awesome \
  305. python3-tqdm \
  306. python3-vcversioner \
  307. python3-semver \
  308. python3-serpent \
  309. python3-spidev \
  310. python3-sqlsoup \
  311. python3-tornado \
  312. python3-trafaret \
  313. python3-urllib3 \
  314. python3-yappi \
  315. python3-texttable \
  316. python3-humanize \
  317. python3-strict-rfc3339 \
  318. python3-supervisor \
  319. python3-diskcache \
  320. python3-requests-futures \
  321. python3-matplotlib \
  322. python3-sentry-sdk \
  323. python3-xlrd \
  324. python3-xstatic \
  325. python3-tzlocal \
  326. python3-ntplib \
  327. python3-u-msgpack-python \
  328. python3-python-vlc \
  329. python3-xlsxwriter \
  330. python3-inflection \
  331. python3-tabulate \
  332. python3-typing-extensions \
  333. python3-pystemd \
  334. python3-pid \
  335. python3-pkgconfig \
  336. python3-pylyrics \
  337. python3-pyyaml \
  338. python3-raven \
  339. python3-stevedore \
  340. python3-requests-oauthlib \
  341. python3-rfc3987 \
  342. python3-psutil \
  343. python3-robotframework-seriallibrary \
  344. python3-pulsectl \
  345. python3-py-ubjson \
  346. python3-pyalsaaudio \
  347. python3-simpleeval \
  348. python3-smbus \
  349. python3-pychromecast \
  350. python3-pyjks \
  351. python3-pymongo \
  352. python3-spidev \
  353. python3-pynacl \
  354. python3-termcolor \
  355. python3-pyperf \
  356. python3-qrcode \
  357. python3-visitor \
  358. python3-pyroute2 \
  359. python3-webencodings \
  360. python3-pyrsistent \
  361. python3-werkzeug \
  362. python3-pydicti \
  363. python3-xmlrunner \
  364. python3-smpplib \
  365. python3-pymisp \
  366. python3-requests-file \
  367. python3-requests-toolbelt \
  368. python3-ruamel-yaml \
  369. python3-socketio \
  370. python3-soupsieve \
  371. python3-textparser \
  372. python3-tinyrecord \
  373. python3-twine \
  374. python3-unidiff \
  375. python3-watchdog \
  376. python3-webcolors \
  377. python3-robotframework \
  378. python3-xxhash \
  379. python3-yarl \
  380. python3-zopeinterface \
  381. python3-requests-ftp \
  382. python3-scapy \
  383. python3-paramiko \
  384. python3-twofish \
  385. python3-simplejson \
  386. python3-snappy \
  387. python3-versiontools \
  388. python3-flask-wtf \
  389. python3-websockets \
  390. python3-werkzeug \
  391. python3-wrapt \
  392. python3-xmltodict \
  393. python3-trafaret-config \
  394. python3-twisted \
  395. python3-txaio \
  396. python3-typeguard \
  397. python3-pytest-timeout \
  398. python3-ujson \
  399. python3-waitress \
  400. python3-websocket-client \
  401. python3-xmodem \
  402. python3-djangorestframework \
  403. python3-pytest-asyncio \
  404. python3-nocasedict \
  405. python3-yamlloader \
  406. python3-ipython \
  407. python3-pycurl \
  408. gyp \
  409. python3-jsonref \
  410. python3-transitions \
  411. python3-dill \
  412. python3-cerberus \
  413. python3-cvxopt \
  414. python3-jsonpath-rw \
  415. "
  416. RDEPENDS_packagegroup-meta-python3-extended = "\
  417. python3-blivet \
  418. ${@bb.utils.contains("DISTRO_FEATURES", "x11", "python3-blivetgui", "", d)} \
  419. python3-cson \
  420. python3-meh \
  421. python3-pyephem \
  422. python3-pykickstart \
  423. python3-pyparted \
  424. python3-pywbem \
  425. python3-pywbemtools \
  426. "
  427. RDEPENDS_packagegroup-meta-python3-connectivity = "\
  428. python3-gsocketpool \
  429. python3-h2 \
  430. python3-hpack \
  431. python3-hyperframe \
  432. python3-priority \
  433. python3-pyconnman \
  434. python3-pyro4 \
  435. python3-thrift \
  436. python3-txws \
  437. python3-pytun \
  438. telepathy-python3 \
  439. "
  440. RDEPENDS_packagegroup-meta-python3-ptest = "\
  441. python3-cryptography-ptest \
  442. python3-jinja2-ptest \
  443. python3-markupsafe-ptest \
  444. "
  445. EXCLUDE_FROM_WORLD = "1"