libtest-warn-perl_0.36.bb 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. SUMMARY = "Test::Warn - Perl extension to test methods for warnings"
  2. DESCRIPTION = "This module provides a few convenience methods for testing \
  3. warning based code. \
  4. \
  5. If you are not already familiar with the Test::More manpage now would be \
  6. the time to go take a look. \
  7. "
  8. SECTION = "libs"
  9. HOMEPAGE= "https://metacpan.org/release/Test-Warn"
  10. LICENSE = "Artistic-1.0 | GPL-1.0+"
  11. LIC_FILES_CHKSUM = "file://README;beginline=73;endline=78;md5=42b423d91c92ba59c215835a2ee9b57a"
  12. CPAN_PACKAGE = "Test-Warn"
  13. CPAN_AUTHOR = "BIGJ"
  14. SRC_URI = "${CPAN_MIRROR}/authors/id/B/BI/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
  15. SRC_URI[md5sum] = "3d958f43d36db263994affde5da09b51"
  16. SRC_URI[sha256sum] = "ecbca346d379cef8d3c0e4ac0c8eb3b2613d737ffaaeae52271c38d7bf3c6cda"
  17. S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
  18. inherit cpan ptest-perl
  19. do_install_ptest() {
  20. cp -r ${B}/blib ${D}${PTEST_PATH}
  21. chown -R root:root ${D}${PTEST_PATH}
  22. }
  23. RDEPENDS_${PN} += " \
  24. libsub-uplevel-perl \
  25. perl-module-blib \
  26. perl-module-carp \
  27. perl-module-test-builder \
  28. perl-module-test-builder-tester \
  29. perl-module-test-tester \
  30. "
  31. RDEPENDS_${PN}-ptest += " \
  32. perl-module-file-spec \
  33. perl-module-test-more \
  34. "
  35. BBCLASSEXTEND = "native nativesdk"