libtest-nowarnings-perl_1.04.bb 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. SUMMARY = "Make sure you didn't emit any warnings while testing"
  2. DESCRIPTION = "In general, your tests shouldn't produce warnings. This \
  3. modules causes any warnings to be captured and stored. It automatically \
  4. adds an extra test that will run when your script ends to check that there \
  5. were no warnings. If there were any warings, the test will give a \\"not ok\\" \
  6. and diagnostics of where, when and what the warning was, including a stack \
  7. trace of what was going on when the it occurred.\
  8. \
  9. If some of your tests are supposed to produce warnings then you should \
  10. be capturing and checking them with Test::Warn, that way \
  11. Test::NoWarnings will not see them and so not complain.\
  12. \
  13. The test is run by an \\"END\\" block in Test::NoWarnings. It will not be \
  14. run when any forked children exit."
  15. SECTION = "libs"
  16. LICENSE = "LGPL-2.1"
  17. HOMEPAGE= "https://metacpan.org/release/Test-NoWarnings"
  18. LIC_FILES_CHKSUM = "file://LICENSE;md5=d8045f3b8f929c1cb29a1e3fd737b499"
  19. CPAN_PACKAGE = "Test-NoWarnings"
  20. CPAN_AUTHOR = "ADAMK"
  21. SRC_URI = "${CPAN_MIRROR}/authors/id/A/AD/${CPAN_AUTHOR}/${CPAN_PACKAGE}-${PV}.tar.gz"
  22. SRC_URI[md5sum] = "682ed043f7d3e38f3dfd8745fd21c49a"
  23. SRC_URI[sha256sum] = "638a57658cb119af1fe5b15e73d47c2544dcfef84af0c6b1b2e97f08202b686c"
  24. RDEPENDS_${PN} += "perl-module-test-builder perl-module-test-more perl-module-test-tester"
  25. S = "${WORKDIR}/${CPAN_PACKAGE}-${PV}"
  26. inherit cpan ptest-perl
  27. BBCLASSEXTEND = "native nativesdk"