libtest-harness-perl_3.42.bb 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. # NOTE:
  2. # You should use perl-module-test-harness instead of this package,
  3. # unless you specifically need a newer version than what is provided
  4. # by perl in oe-core.
  5. SUMMARY = "Test::Harness - Run Perl standard test scripts with statistics"
  6. DESCRIPTION = "Although, for historical reasons, the Test::Harness \
  7. distribution takes its name from this module it now exists only to provide \
  8. TAP::Harness with an interface that is somewhat backwards compatible \
  9. with Test::Harness 2.xx. If you're writing new code consider using \
  10. TAP::Harness directly instead. \
  11. \
  12. Emulation is provided for runtests and execute_tests but the \
  13. pluggable 'Straps' interface that previous versions of Test::Harness \
  14. supported is not reproduced here. Straps is now available as a stand \
  15. alone module: Test::Harness::Straps. \
  16. \
  17. See TAP::Parser, TAP::Harness for the main documentation for this \
  18. distribution."
  19. SECTION = "libs"
  20. HOMEPAGE = "http://testanything.org"
  21. LICENSE = "Artistic-1.0 | GPL-1.0+"
  22. LIC_FILES_CHKSUM = "file://README;beginline=29;endline=30;md5=b08db4360eec119e875dddd7cb8a5ddd"
  23. SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Test-Harness-${PV}.tar.gz"
  24. SRC_URI[md5sum] = "c794906473f88d6b74194e2d56f16bd6"
  25. SRC_URI[sha256sum] = "0fd90d4efea82d6e262e6933759e85d27cbcfa4091b14bf4042ae20bab528e53"
  26. UPSTREAM_CHECK_REGEX = "Test\-Harness\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
  27. S = "${WORKDIR}/Test-Harness-${PV}"
  28. inherit cpan ptest-perl
  29. RDEPENDS_${PN} += "\
  30. perl-module-benchmark \
  31. "
  32. RPROVIDES_${PN} += "libapp-prove-perl \
  33. libapp-prove-state-perl \
  34. libapp-prove-state-result-perl \
  35. libapp-prove-state-result-test-perl \
  36. libtap-base-perl \
  37. libtap-formatter-base-perl \
  38. libtap-formatter-color-perl \
  39. libtap-formatter-console-perl \
  40. libtap-formatter-console-parallelsession-perl \
  41. libtap-formatter-console-session-perl \
  42. libtap-formatter-file-perl \
  43. libtap-formatter-file-session-perl \
  44. libtap-formatter-session-perl \
  45. libtap-harness-perl \
  46. libtap-harness-env-perl \
  47. libtap-object-perl \
  48. libtap-parser-perl \
  49. libtap-parser-aggregator-perl \
  50. libtap-parser-grammar-perl \
  51. libtap-parser-iterator-perl \
  52. libtap-parser-iterator-array-perl \
  53. libtap-parser-iterator-process-perl \
  54. libtap-parser-iterator-stream-perl \
  55. libtap-parser-iteratorfactory-perl \
  56. libtap-parser-multiplexer-perl \
  57. libtap-parser-result-perl \
  58. libtap-parsser-result-bailout-perl \
  59. libtap-parser-result-comment-perl \
  60. libtap-parser-result-plan-perl \
  61. libtap-parser-result-pragma-perl \
  62. libtap-parser-result-test-perl \
  63. libtap-parser-result-unknown-perl \
  64. libtap-parser-result-version-perl \
  65. libtap-parser-result-yaml-perl \
  66. libtap-parser-resultfactory-perl \
  67. libtap-parser-scheduler-perl \
  68. libtap-parser-scheduler-job-perl \
  69. libtap-parser-scheduler-spinner-perl \
  70. libtap-parser-source-perl \
  71. libtap-parser-sourcehandler-perl \
  72. libtap-parser-sourcehandler-executable-perl \
  73. libtap-parser-sourcehandler-file-perl \
  74. libtap-parser-sourcehandler-handle-perl \
  75. libtap-parser-sourcehandler-perl-perl \
  76. libtap-parser-sourcehandler-rawtap-perl \
  77. libtap-parser-yamlish-reader-perl \
  78. libtap-parser-yamlish-writer-perl \
  79. "
  80. do_install_prepend() {
  81. # these tests are inappropriate on target
  82. rm -rf ${B}/t/000-load.t
  83. rm -rf ${B}/t/state.t
  84. # these tests require "-T" (taint) option on command line
  85. rm -rf ${B}/t/aggregator.t
  86. rm -rf ${B}/t/bailout.t
  87. rm -rf ${B}/t/base.t
  88. rm -rf ${B}/t/callbacks.t
  89. rm -rf ${B}/t/errors.t
  90. rm -rf ${B}/t/nested.t
  91. rm -rf ${B}/t/object.t
  92. rm -rf ${B}/t/premature-bailout.t
  93. rm -rf ${B}/t/results.t
  94. rm -rf ${B}/t/streams.t
  95. rm -rf ${B}/t/yamlish-output.t
  96. rm -rf ${B}/t/compat/version.t
  97. }
  98. do_install_append() {
  99. install -d ${D}/usr/local/bin
  100. # do not clobber perl-misc /usr/bin/prove
  101. install -m 0755 ${B}/bin/prove ${D}/usr/local/bin/
  102. rm -rf ${D}${bindir}/prove
  103. rm -rf ${D}${bindir}
  104. }
  105. FILES_${PN} += "/usr/local/bin/prove"
  106. BBCLASSEXTEND = "native"