libtest-deep-perl_1.130.bb 2.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. SUMMARY = "Test::Deep - Extremely flexible deep comparison"
  2. DESCRIPTION = "If you don't know anything about automated testing in Perl \
  3. then you should probably read about Test::Simple and Test::More before \
  4. preceding. Test::Deep uses the Test::Builder framework. \
  5. \
  6. Test::Deep gives you very flexible ways to check that the result you got is \
  7. the result you were expecting. At its simplest it compares two structures \
  8. by going through each level, ensuring that the values match, that arrays and \
  9. hashes have the same elements and that references are blessed into the \
  10. correct class. It also handles circular data structures without getting \
  11. caught in an infinite loop. \
  12. \
  13. Where it becomes more interesting is in allowing you to do something besides \
  14. simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
  15. strings are exactly equal but sometimes that's not what you want. When you \
  16. don't know exactly what the string should be but you do know some things \
  17. about how it should look, \'eq\' is no good and you must use pattern matching \
  18. instead. Test::Deep provides pattern matching for complex data structures \
  19. distribution."
  20. SECTION = "libs"
  21. HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
  22. LICENSE = "Artistic-1.0 | GPL-1.0+"
  23. LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=a897a42bafc3422cab17c2eb94f87a7c"
  24. SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
  25. SRC_URI[md5sum] = "d466e471108f7f7a5df3802cb13761ac"
  26. SRC_URI[sha256sum] = "4064f494f5f62587d0ae501ca439105821ee5846c687dc6503233f55300a7c56"
  27. UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
  28. S = "${WORKDIR}/Test-Deep-${PV}"
  29. inherit cpan ptest-perl
  30. RDEPENDS_${PN} += " \
  31. perl-module-dynaloader \
  32. perl-module-exporter \
  33. perl-module-fcntl \
  34. perl-module-list-util \
  35. perl-module-scalar-util \
  36. perl-module-strict \
  37. perl-module-vars \
  38. perl-module-warnings \
  39. "
  40. RDEPENDS_${PN}-ptest += " \
  41. perl-module-if \
  42. perl-module-lib \
  43. perl-module-test-more \
  44. perl-module-test-tester \
  45. "
  46. BBCLASSEXTEND = "native"