libstrictures-perl_2.000006.bb 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. SUMMARY = "strictures - turn on strict and make all warnings fatal"
  2. DESCRIPTION = "I've been writing the equivalent of this module at the top \
  3. of my code for about a year now. I figured it was time to make it shorter. \
  4. \
  5. Things like the importer in \"use Moose\" don't help me because they turn \
  6. warnings on but don't make them fatal -- which from my point of view is \
  7. useless because I want an exception to tell me my code isn't warnings-clean. \
  8. \
  9. Any time I see a warning from my code, that indicates a mistake. \
  10. \
  11. Any time my code encounters a mistake, I want a crash -- not spew to STDERR \
  12. and then unknown (and probably undesired) subsequent behaviour. \
  13. \
  14. I also want to ensure that obvious coding mistakes, like indirect object \
  15. syntax (and not so obvious mistakes that cause things to accidentally compile \
  16. as such) get caught, but not at the cost of an XS dependency and not at the \
  17. cost of blowing things up on another machine. \
  18. \
  19. Therefore, \"strictures\" turns on additional checking, but only when it \
  20. thinks it's running in a test file in a VCS checkout -- although if this \
  21. causes undesired behaviour this can be overridden by setting the \
  22. PERL_STRICTURES_EXTRA environment variable."
  23. SECTION = "libs"
  24. HOMEPAGE = "https://metacpan.org/pod/strictures"
  25. LICENSE = "Artistic-1.0 | GPL-1.0+"
  26. LIC_FILES_CHKSUM = "file://README;beginline=246;endline=262;md5=43be558cf4f19823cdd6af22135cf5f8"
  27. SRC_URI = "${CPAN_MIRROR}/authors/id/H/HA/HAARG/strictures-${PV}.tar.gz"
  28. SRC_URI[md5sum] = "35c14fd25320f32ff40e977feae95d0d"
  29. SRC_URI[sha256sum] = "09d57974a6d1b2380c802870fed471108f51170da81458e2751859f2714f8d57"
  30. S = "${WORKDIR}/strictures-${PV}"
  31. inherit cpan ptest-perl
  32. RDEPENDS_${PN} += " \
  33. perl-module-carp \
  34. perl-module-strict \
  35. perl-module-test-more \
  36. perl-module-warnings \
  37. "
  38. RDEPENDS_${PN}-ptest += "perl-module-perlio perl-module-perlio-scalar"
  39. BBCLASSEXTEND = "native"