libmodule-pluggable-perl_5.2.bb 1.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. SUMMARY = "Automatically give your module the ability to have plugins"
  2. DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
  3. having 'plugins' for your module. Obviously this isn't going to be the \
  4. be all and end all of solutions but it works for me.\
  5. \
  6. Essentially all it does is export a method into your namespace that \
  7. looks through a search path for .pm files and turn those into class \
  8. names.\
  9. \
  10. Optionally it instantiates those classes for you."
  11. SECTION = "libs"
  12. AUTHOR = "Simon Wistow <simon@thegestalt.org>"
  13. HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
  14. LICENSE = "Artistic-1.0 | GPL-1.0+"
  15. LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
  16. SRCNAME = "Module-Pluggable"
  17. SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz"
  18. SRC_URI[md5sum] = "87ce2971662efd0b69a81bb4dc9ea76c"
  19. SRC_URI[sha256sum] = "b3f2ad45e4fd10b3fb90d912d78d8b795ab295480db56dc64e86b9fa75c5a6df"
  20. PR = "r1"
  21. UPSTREAM_CHECK_REGEX = "Module\-Pluggable\-(?P<pver>(\d+\.\d+))"
  22. UPSTREAM_CHECK_URI = "https://metacpan.org/release/${SRCNAME}"
  23. S = "${WORKDIR}/${SRCNAME}-${PV}"
  24. inherit cpan
  25. RDEPENDS_${PN} = " perl-module-base \
  26. perl-module-deprecate \
  27. perl-module-file-basename \
  28. perl-module-file-find \
  29. perl-module-file-spec \
  30. perl-module-file-spec-functions \
  31. perl-module-if \
  32. perl-module-test-more \
  33. "
  34. BBCLASSEXTEND = "native"