libmodule-build-tiny-perl_0.039.bb 2.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build"
  2. DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
  3. Makefile.PL file to drive distribution configuration, build, test and \
  4. installation. Traditionally, Build.PL uses Module::Build as the underlying \
  5. build system. This module provides a simple, lightweight, drop-in replacement. \
  6. Whereas Module::Build has over 6,700 lines of code; this module has less than \
  7. 120, yet supports the features needed by most distributions."
  8. SECTION = "libs"
  9. HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/"
  10. LICENSE = "Artistic-1.0 | GPL-1.0+"
  11. LIC_FILES_CHKSUM = "file://LICENSE;md5=57b8100f0b648cd37fbc3725fe3c111a"
  12. DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native"
  13. SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz"
  14. SRC_URI[md5sum] = "2332c90c17454107fea3f2614e11a3a9"
  15. SRC_URI[sha256sum] = "7d580ff6ace0cbe555bf36b86dc8ea232581530cbeaaea09bccb57b55797f11c"
  16. S = "${WORKDIR}/Module-Build-Tiny-${PV}"
  17. inherit cpan_build
  18. do_install () {
  19. cpan_build_do_install
  20. }
  21. RDEPENDS_${PN} = " libextutils-config-perl \
  22. libextutils-helpers-perl \
  23. libextutils-installpaths-perl \
  24. perl-module-xsloader \
  25. perl-module-file-spec \
  26. perl-module-io-handle \
  27. perl-module-tap-harness-env \
  28. perl-module-ipc-open3 \
  29. perl-module-file-path \
  30. perl-module-cpan \
  31. perl-module-extutils-cbuilder \
  32. perl-module-getopt-long \
  33. perl-module-extutils-makemaker \
  34. perl-module-exporter \
  35. perl-module-carp \
  36. perl-module-test-more \
  37. perl-module-text-parsewords \
  38. perl-module-load \
  39. perl-module-file-temp \
  40. perl-module-data-dumper \
  41. perl-module-extutils-parsexs \
  42. perl-module-pod-man \
  43. perl-module-json-pp \
  44. "
  45. BBCLASSEXTEND = "native"