libmime-types-perl_2.17.bb 1.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. SUMMARY = "MIME::Types - Definition of MIME types"
  2. DESCRIPTION = "MIME types are used in MIME compliant lines, for instance \
  3. as part of e-mail and HTTP traffic, to indicate the type of content which \
  4. is transmitted. Sometimes real knowledge about a mime-type is need.\
  5. \n\
  6. This module maintains a set of MIME::Type objects, which each describe \
  7. one known mime type."
  8. HOMEPAGE = "http://search.cpan.org/~markov/MIME-Types-${PV}"
  9. SECTION = "libraries"
  10. LICENSE = "Artistic-1.0|GPLv1+"
  11. LIC_FILES_CHKSUM = "file://META.yml;beginline=11;endline=11;md5=963ce28228347875ace682de56eef8e8"
  12. SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/MIME-Types-${PV}.tar.gz \
  13. file://run-ptest \
  14. "
  15. SRC_URI[md5sum] = "6f1441addab947137bac92c379a47ba3"
  16. SRC_URI[sha256sum] = "e04ed7d42f1ff3150a303805f2689c28f80b92c511784d4641cb7f040d3e8ff6"
  17. S = "${WORKDIR}/MIME-Types-${PV}"
  18. inherit cpan ptest
  19. RDEPENDS_${PN} = "\
  20. perl-module-base \
  21. perl-module-file-basename \
  22. perl-module-file-spec \
  23. perl-module-overload \
  24. "
  25. RDEPENDS_${PN}-ptest = "perl-module-lib perl-module-test-more"
  26. #RSUGGESTS_${PN}-ptest = "libmojo-base-perl"
  27. do_install () {
  28. cpan_do_install
  29. install -d ${D}${bindir}
  30. install -m 755 ${S}/bin/collect-types ${D}${bindir}/collect-types
  31. }
  32. do_install_ptest () {
  33. cp -r ${B}/t ${D}${PTEST_PATH}
  34. }