libhtml-parser-perl_3.72.bb 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. DESCRIPTION = "This package contains the Parser.pm module with friends."
  2. HOMEPAGE = "https://metacpan.org/release/HTML-Parser"
  3. SECTION = "libs"
  4. LICENSE = "Artistic-1.0 | GPL-1.0+"
  5. LIC_FILES_CHKSUM = "file://README;md5=b0459e4426b94753b9a9b8a15f1223b8"
  6. DEPENDS += "perl"
  7. SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/HTML-Parser-${PV}.tar.gz"
  8. SRC_URI[md5sum] = "eb7505e5f626913350df9dd4a03d54a8"
  9. SRC_URI[sha256sum] = "ec28c7e1d9e67c45eca197077f7cdc41ead1bb4c538c7f02a3296a4bb92f608b"
  10. S = "${WORKDIR}/HTML-Parser-${PV}"
  11. EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
  12. inherit cpan ptest-perl
  13. do_compile() {
  14. export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
  15. cpan_do_compile
  16. }
  17. RDEPENDS_${PN} += "\
  18. perl-module-exporter \
  19. perl-module-strict \
  20. perl-module-vars \
  21. perl-module-xsloader \
  22. libhtml-tagset-perl \
  23. "
  24. RDEPENDS_${PN}-ptest += "\
  25. liburi-perl \
  26. perl-module-config \
  27. perl-module-file-spec \
  28. perl-module-filehandle \
  29. perl-module-io-file \
  30. perl-module-selectsaver \
  31. perl-module-test \
  32. perl-module-test-more \
  33. "
  34. BBCLASSEXTEND = "native"