libdata-hexdump-perl_0.02.bb 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. SUMMARY = "Data::HexDump - Hexadecial Dumper"
  2. DESCRIPTION = "Dump in hexadecimal the content of a scalar. The result \
  3. is returned in a string. Each line of the result consists of the offset \
  4. in the source in the leftmost column of each line, followed by one or \
  5. more columns of data from the source in hexadecimal. The rightmost column \
  6. of each line shows the printable characters \
  7. (all others are shown as single dots).\
  8. "
  9. HOMEPAGE = "http://search.cpan.org/~ftassin/Data-HexDump-0.02/lib/Data/HexDump.pm"
  10. SECTION = "libs"
  11. LICENSE = "Artistic-1.0"
  12. LIC_FILES_CHKSUM = "file://lib/Data/HexDump.pm;beginline=215;endline=217;md5=bf1cd9373f8d1f85fe091ee069a480e9"
  13. DEPENDS = "perl"
  14. SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FT/FTASSIN/Data-HexDump-${PV}.tar.gz \
  15. file://run-ptest \
  16. "
  17. SRC_URI[md5sum] = "467b7183d1062ab4a502b50c34e7d67f"
  18. SRC_URI[sha256sum] = "1a9d843e7f667c1c6f77c67af5d77e7462ff23b41937cb17454d03535cd9be70"
  19. S = "${WORKDIR}/Data-HexDump-${PV}"
  20. inherit cpan ptest update-alternatives
  21. do_install_ptest () {
  22. install -d ${D}${PTEST_PATH}/t
  23. install -m 0755 ${B}/t/* ${D}${PTEST_PATH}/t
  24. }
  25. BBCLASSEXTEND = "native"
  26. ALTERNATIVES_PRIORITY = "100"
  27. ALTERNATIVE_${PN} = "hexdump"
  28. ALTERNATIVE_LINK_NAME[hexdump] = "${bindir}/hexdump"