libcurses-perl_1.37.bb 732 B

1234567891011121314151617181920212223242526
  1. DESCRIPTION = "lib-curses provides an interface between Perl programs and \
  2. the curses library."
  3. SECTION = "libs"
  4. LICENSE = "Artistic-1.0 | GPL-1.0+"
  5. LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
  6. DEPENDS += "perl ncurses "
  7. SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz"
  8. SRC_URI[md5sum] = "aede9d1ed9856eff89f4ce208ee59de0"
  9. SRC_URI[sha256sum] = "74707ae3ad19b35bbefda2b1d6bd31f57b40cdac8ab872171c8714c88954db20"
  10. S = "${WORKDIR}/Curses-${PV}"
  11. EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
  12. inherit cpan
  13. do_compile() {
  14. export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
  15. cpan_do_compile
  16. }